Dashboards Slow to Respond
Incident Report for SimpleReach
Resolved
All systems have caught up and dashboards and reports are loading normally.
Posted over 1 year ago. Mar 22, 2018 - 17:46 EDT
Investigating
Reports and dashboards are currently running behind which may cause some screens to load slowly. Data collection remains unaffected and our systems will be caught up shortly. Please reach out to success@simplereach.com with any questions.
Posted over 1 year ago. Mar 22, 2018 - 17:19 EDT