Reports Delay
Incident Report for SimpleReach
Resolved
This incident has been resolved.
Posted over 2 years ago. Feb 03, 2017 - 13:26 EST
Monitoring
Reports and exports for article data are currently running behind. Data collection remains unaffected and our systems will be caught up shortly.
Posted over 2 years ago. Feb 03, 2017 - 10:35 EST