Reporting Connectivity Issue
Incident Report for SimpleReach
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jun 27, 2017 - 10:53 EDT
Investigating
We are currently investigating issues with loading dashboards and reports. Data collection remains unaffected. We are working to resolve the issue shortly.
Posted almost 2 years ago. Jun 27, 2017 - 10:21 EDT