Data is Behind
Incident Report for SimpleReach
Resolved
This incident has been resolved.
Posted over 1 year ago. May 03, 2018 - 14:46 EDT
Identified
Data is slow to load for April 30th, 2018. This affects both dashboards and exports. We have identified the issue and will have a fix in shortly. For any questions, please reach out to success@simplereach.com.
Posted over 1 year ago. May 01, 2018 - 11:32 EDT