Data is behind
Incident Report for SimpleReach
Resolved
This incident has been resolved.
Posted 10 months ago. Oct 03, 2018 - 18:05 EDT
Identified
Data is slow to load for October 2nd and 3rd. This affects both dashboards and exports. We have identified the issue and will have a fix in shortly. For any questions, please reach out to success@simplereach.com.
Posted 10 months ago. Oct 03, 2018 - 10:52 EDT