Scheduled Maintenance
Incident Report for SimpleReach
Resolved
Scheduled maintenance went smoothly. Services have been restored
Posted almost 3 years ago. Nov 25, 2016 - 10:28 EST
Investigating
We are performing scheduled maintenance on our reporting database. Historical reports and dashboards may be unavailable.
Posted almost 3 years ago. Nov 25, 2016 - 08:31 EST