Data Backfill
Incident Report for SimpleReach
Resolved
This incident has been resolved.
Posted almost 3 years ago. Nov 29, 2016 - 17:14 EST
Identified
Data Backfill in Progress. All data for 2016 has been restored. Data for 2015 is in progress and will be completed by end of day. Please reach out to your Customer Success Managers with any questions.
Posted almost 3 years ago. Nov 29, 2016 - 08:55 EST