Dashboards behind
Incident Report for SimpleReach
Resolved
The issue has been resolved.
Posted 10 months ago. Oct 05, 2018 - 13:56 EDT
Investigating
Reports and dashboards are currently running behind which may cause some screens to load slowly. Data collection remains unaffected and our systems will be caught up shortly. Please reach out to success@simplereach.com with any questions.
Posted 10 months ago. Oct 05, 2018 - 10:45 EDT