Privacy Policy Changes
Incident Report for SimpleReach
Resolved
This incident has been resolved.
Posted 8 months ago. May 28, 2018 - 16:45 EDT
Investigating
We've recently made some changes to our Privacy Policy. You can read it in full here: https://simplereach.com/privacy
Posted 8 months ago. May 25, 2018 - 12:00 EDT