Content Metadata Issues
Incident Report for SimpleReach
Resolved
This incident has been resolved.
Posted about 1 year ago. Feb 23, 2018 - 16:21 EST
Identified
We have identified an issue with content metadata loading slowly in the application. The cause has been identified and we are working towards solving the issue within the next hour. If any issues persist, please reach out to success@simplereach.com.
Posted about 1 year ago. Feb 23, 2018 - 13:35 EST